Newsmeldung zu 686B-Bug fehlerhaft!

Diskutiere Newsmeldung zu 686B-Bug fehlerhaft! im Feedback @ TecCentral Forum im Bereich Informationen & Feedback; Hallo! Ihr habt ja sicher alle die Sache mit dem DMA-Transfer Bug in Via's neuer Southbrigde gelesen, dem Au-Ja! und Planet3D-Now auf die Schliche gekommen ...



Ergebnis 1 bis 8 von 8
 
  1. Newsmeldung zu 686B-Bug fehlerhaft! #1
    Newbie Standardavatar

    Standard

    Hallo!

    Ihr habt ja sicher alle die Sache mit dem DMA-Transfer Bug in Via's neuer Southbrigde gelesen, dem Au-Ja! und Planet3D-Now auf die Schliche gekommen sind. Ich denke daß dürfte die vielen diffusen, nur schwer nachvollziehbaren Probleme und Problemchen mit denen sich die Besitzer der KT133A Boards rumzuschlagen hatten auf einen Schlag erklärbar machen. Ich habe ein Epox 8KTA-3, und oft Screenfreezes, oder gelegentlich gar Systemabstürze beim kopieren großer Datenmengen bemerkt. Nie wäre ich auf die Idee gekommen, ein fehlerhafter PCI/IDE-Controller könnte die Schuld daran tragen... nun, mit dem Workarround von Au-Ja! läuft mein System nun endlich zuverlässig und stabil.

    Soweit, sogut. Leider muß ich Euch mitteilen daß Eure Newsmeldung zu diesem für alle Via-Mainboard-Besitzer enorm wichtigen Thema die Tatsachen vollkommen falsch wiedergibt. Ich weiß nicht wo (und ob überhaupt) der Autor der Newsmeldung diese vollkommen falschen Fakten recherchiert hat, aber tatsache ist:

    1.
    Der BUG in der Southbrigde verursacht Datentransfehrfehler wenn Daten von einem IDE-Kanal zum anderen transferiert werden und  wenn Daten innerhalb eines IDE-Kanals transferiert werden, wie in der Newsmeldung steht;

    und 2.
    betrifft dieser Fehler keineswegs nur ATA-100 Festplatten, sondern ALLE IDE-Device-Geräte die im DMA Modus betrieben werden, dabei ist es vollkommen unerheblich um welchen DMA-Modus es sich handelt, im UDMA soll des Problem jedoch verstärtk auftreten. Damit sind CD-ROM's, Brenner etc. ebenso betroffen wie Festplatten!!

    Damit ist die Situation also weit kritischer als die Newsmeldung auf TecCentral fälschlicherweise suggeriert. Betroffenen Nutzer kann ich nur empfehlen den Artikel auf www.au-ja.de durchzulesen, und dem dort angebotenen Workarround zu folgen, der bei mir sämtliche Probleme vorerst beseitigen konnte.

    MfG,
    Northpack

  2. Standard

    Hallo Northpack,

    schau Dir mal Diesen Ratgeber. an. Dort wirst du bestimmt fündig.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Newsmeldung zu 686B-Bug fehlerhaft! #2
    Volles Mitglied Avatar von Till

    Standard

    So....

    Also, erst mal danke, dass du das für uns nachgeschaut hast, die News war tatsächlich teilweise Fehlerhaft.

    "Ich weiß nicht wo (und ob überhaupt) der Autor der Newsmeldung diese vollkommen falschen Fakten recherchiert hat..."

    Diese "falschen" Fakten stammen von tecchannel, wie das auch wie immer als Quellenangabe in der News steht... Der Autor bin übrigens ICH...
    Die News habe ich bereits korrigiert, was den Fehler mit den IDE-Kanälen betrifft. (Bei dir Punkt 1)
    Zu Punkt 2: Bei tecchannel steht in den News, und auf diese beziehe ich mich bei meinen News: "Beim Kopieren zwischen zwei Festplatten, die im UDMA-Modus laufen, können Daten verloren gehen oder korrumpiert werden." Nichts anderes steht in den News, die ich verfasst habe. Somit sehe ich hier auch keinen Fehler in den News.

    Danke nochmals für deinen Hinweis, in Zukunft reicht es auch, wenn du mir einen kurzen Hinweis per Mail schickst, wenn du einen Fehler entdeckst, ich werde die News dann schnellstmöglich überarbeiten. Wer die News geschrieben hat steht in der Regel am Ende des Textes, und die zugehörigen E-Mailadressen findest du im Impressum bei http://www.TecCentral.de.


    MfG Till

  4. Newsmeldung zu 686B-Bug fehlerhaft! #3
    Zidane
    Besucher Standardavatar

    Standard

    Dieser Fehler sollte dan auch bei meinem LS120 auftauchen..das momentan..im MultiwordDMA1-Modus
    arbeitet..es ist am Sec.Port angeschlossen...als Master..
    Zum Test einmal eine 120..Zip Datei von C: nach A: und
    zurückkopieren...mal sehen was passiert...Ürigens betrifft das Problem nicht nur Festplatten sondern auch
    SB-Live karte wie ich selber festgetellt..habe inbesondere der SB-16Emu-Modus läßt den PC abschmiren..obwohl keine IRQ--oder speicherkonflikte
    vorliegen...nachdem ich im Bios 2 parameter verstellt habe ging es...Oder worauf sonst kann dieser Fehler
    bassieren...bitte um korrektur falls ich falsch liege...Danke...

  5. Newsmeldung zu 686B-Bug fehlerhaft! #4
    Zidane
    Besucher Standardavatar

    Standard

    ZUSATZ:

    Beim Spielen von DOS Spielen unter Windows oder DOS
    die diesen Modus benötigen...

  6. Newsmeldung zu 686B-Bug fehlerhaft! #5
    Newbie
    Threadstarter
    Standardavatar

    Standard

    Re-Hallo!

    Also ersteinmal muß ich mich dafür entschuldigen, daß mein obiges Posting vieleicht etwas sehr "offensiv" rübergekommen ist, es war jedenfalls nicht meine Absicht den Autor irgendetwas zu unterstellen. Ich wollte eben darauf hinweisen, daß die Newsmeldung fehlerhaft war, weil ich eigentlich die seriöse Berichterstattung auf TecCentral.de eigentlich immer sehr schätze, weswegen mich diese Meldung vieleicht etwas irritiert hat

    Zur Quellenangabe: Die habe ich eingesehen, und darauf bezog sich der von dir zitierte Satz. Dort wird nämlich, im Gegensatz zu der inzwischen korrigierten Newsmeldung auf TecCentral zumindest die Tatsache, daß der Fehler bei Tranfers zwischen den beiden IDE-Kanälen auftaucht korrtekt wiedergegeben. Aber vieleicht haben die das ja auch mittlerweile korrigiert!?
    Nunja, was nachwievor bei beiden Meldungen nicht ganz vollständig wiedergegeben wird, ist die Tatsache das dieser Fehler auch Tranfers von CD oder DVD auf die Festplatte, oder von Festplatte auf einen Brenner betrifft. Besonders die Sache mit dem Brenner ist doch recht heimtückisch, weil man den normalerweise eben am 2. IDE Port hängen hat, und wenn nur alle 1,x GB ein fehler auftritt so reich dies dennoch aus, um 1 von 2 Rohlingen zu "verbraten"! Ich denke daß dies auch die Erklärung für die vielen Brennerprobleme in Zusammenhang diesem Boards sein könnte (ist?).

    Der absolute Overkill wäre natürlich die beliebte verlegung der Auslagerungsdatei auf eine seperaten Platte am 2. IDE-Kanal... dazu noch eine SB-Live! im System und Du kannst Dir gleich den Rechner um den Hals binden und damit von der Brücke hoppsen

    @Zidane.

    Der "betrifft" nicht in diesem Sinne SB-Live Karten, sondern durch das vorhandensein einer solchen Karte im System provoziert. Das liegt nach den bisherigen Stand der Ermittlungen wohl daran, daß der SB-Live die eigenheit hat, auch wenn er gerade nicht genutzt, wird (d.h. keine Sounds abgespielt werden), pausenlos Nullbytes über den PCI-Bus zu senden, so daß dieser alleine durch das vorhandensein der Karte schon zu ca. 305 ausgelastet ist! Und da der Fehler durch eine mangelhafte Handhabung der Konkurenzsituation bei Datentranfsers im DMA-Modus verursacht wird - die Datenströme der Geräte "kollidieren" sozusagen miteinander, begünstigt dies das autreten natürlich im hohen Maße.

    Wenn Du dein System auf diesen Fehler hin überprüfen willst, musst Du aber vermutlich etwas mehr Zeit und Kopiervorgänge investieren, selbst bei einem System mit SB-Live ist es glüklicherweise eher unwarscheinlich das sich der fehler direkt beim 1. Kopiervorgang bemerkbar macht. Deswegen gilt ein System nach den von Au-Ja! angewendeten  Testmnethoden auch erst dann als "sicher", wenn es 200 Kopiervorgänge der 133MB-Datei fehlerfrei bewältigt hat.

    MfG,
    Northpack

    (Geändert von Northpack um 19:55 - 13. April 2001)

  7. Newsmeldung zu 686B-Bug fehlerhaft! #6
    Zidane
    Besucher Standardavatar

    Standard

    Amen...Aber bevor Ihr jetzt alle von der Brücke springt..erst mal nachgucken...ob im Bios einstellungsmäßig was zu retten ist...und ob ihr eine SB drin habt..wenn nicht...oder ihr habt nur eine Platte
    dann überlegt es euch nochmal...ansonsten wenn nichts
    zu retten ist...bis zum nächsten Leben Amen !

  8. Newsmeldung zu 686B-Bug fehlerhaft! #7
    Newbie
    Threadstarter
    Standardavatar

    Standard

    Zidane.

    Ich war grad dabei mein Posting oben zu editieren, gucks Dir nochmal an

    Die Bioseinstellungen müssen nicht zwangsweise vorhanden sein. Wäre natürlich komfortabler, aber bei meinem Epox-8kta3 musste ich das Tool WPCREDIT benutzen. Das dürfte mit Hilfe der Beschreibung bei Au-Ja! aber eigentlich kein allzugroßes Problem darstellen.

    Wo die Bombe jetzt aber ersteinmal geplatzt ist, denke ich das die Boardhersteller reagieren werden, und zumindest diese Einstellungen in den nächsten Bios-Versionen deaktiviert sein werden.

    MfG,
    Northpack

  9. Newsmeldung zu 686B-Bug fehlerhaft! #8
    Zidane
    Besucher Standardavatar

    Standard

    Jaa...in der Tat die Bombe ist geplatzt...wie ich gelesen
    hat, hat VIA den Fehler zugegeben..und wird Bios
    Versionen rausbringen..bei Epox soll es los gehen..
    Bei meinem Epox8KTA3...fehlt die 3 Option
    PCI-Master-Read-cacheable...disabled....aber die ersten
    Optionen haben was gebracht...


Newsmeldung zu 686B-Bug fehlerhaft!

Besucher kamen mit folgenden Begriffen auf die Seite:

Stichworte


Guides, Tipps und Mitspieler zu Citadel: Forged with Fire findest du auf Citadel Forum - Forged with Fire.
-
Trete der Nintendo Community bei und besuche das Nintendo Switch Forum.